Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Sign in to follow this  
Nielo

Firefox not loading CSS for TDN for me

Recommended Posts

Yesterday Firefox stopped loading the CSS for TDN for me, so the page is showing up in a fairly bare-bones form. (The forums are loading fine though.) It looks normal on Chrome, and no other sites are giving me issues. The problem seems to be that Firefox considers the mixed contents to be unsafe. I know I can get the site to load properly again by switching off the protection, but I was just wondering if anyone else has the same issue.

Share this post


Link to post
Share on other sites

I'm using Firefox and there's no problem for me. *touches wood* I wonder why it's NOT doing it to me.

Share this post


Link to post
Share on other sites

It loads fine, for me, but I do not "surf" on TDN in "Incognito" or "Private" mode. I mainly use Firefox. You mentioned it works normally when you switch off "protection". Is that an add-on or Firefox's "Private" mode? Latest Firefox is 61.0.1. Is your FF up-to-date?

Share this post


Link to post
Share on other sites

@Scoobert_Doo No, it's not an add-on; I mean that when I click on the lock next to where it shows the URL, it mentions the connection isn't secure, and clicking that gives the option to switch off the protection which is responsible for blocking the CSS. And yes, that's the same version of Firefox I have.

I've been thinking about what I could've updated/installed to make this happen, but it first occurred yesterday, after I'd already had the site open for a while without issues. I went to use the search function, and that's when I noticed things weren't loading. I figured my connection was just slow or something, and forgot all about, but then it happened again today. I don't think I downloaded/updated anything yesterday, at least not consciously, so it's a bit confusing, especially since this appears to be the only site that's doing it. ?

I've already taken a look at these steps on the Firefox trouble shooting site, but they weren't much use, since I don't have any of the programs that they mentioned installed, and already ran a Malware scan. And if it was a problem with TDN, more people would be affected by it.

Share this post


Link to post
Share on other sites
29 minutes ago, Scoobert_Doo said:

You mentioned it works normally when you switch off "protection". Is that an add-on or Firefox's "Private" mode? Latest Firefox is 61.0.1. Is your FF up-to-date?

Thanks for bringing that up, Scoobs! A bit of my brain wondered what the protection was, but not the bit that actually could ask the question, lol. So thank you for being my outside brain. ?

Share this post


Link to post
Share on other sites
4 minutes ago, jellysundae said:

Thanks for bringing that up, Scoobs! A bit of my brain wondered what the protection was, but not the bit that actually could ask the question, lol. So thank you for being my outside brain. ?

Maybe I should've been clearer on that, but I'm loosely translating it, as my Firefox is in Dutch. Otherwise I'd have just included a screenshot, but the link I put in my last post shows almost the same thing, except that the lock on TDN doesn't have a red line over it, but a yellow/orange exlamation mark.

Share this post


Link to post
Share on other sites

Ah, I see. I'm getting it now. I typed directly into the address bar (without the quotes) "thedailyneopets.com" and it shows everything in hyperlinks, and no graphics. Strange, though, when I click on the "The Daily Neopets" link in the Forums, the site displays properly.

EDIT: I haven't cleared my cache, cookies, and history in a while, so that could be part of it. When I go to "thedailyneopets.com", it "forces" the site to "https://thedailyneopets.com". As The Daily Neopets hasn't gone to https yet, I believe Firefox is trying to keep you safe. Why www.thedailyneopets.com shows normal, is strange.

Share this post


Link to post
Share on other sites
1 minute ago, Scoobert_Doo said:

Ah, I see. I'm getting it now. I typed directly into the address bar (without the quotes) "thedailyneopets.com" and it shows everything in hyperlinks, and no graphics. Strange, though, when I click on the "The Daily Neopets" link in the Forums, the site displays properly.

That's odd, but yes, that's what the site has looked like for me since yesterday. The link from the forum isn't showing the site correctly for me though.

Share this post


Link to post
Share on other sites
2 minutes ago, Nielo said:

That's odd, but yes, that's what the site has looked like for me since yesterday. The link from the forum isn't showing the site correctly for me though.

What happens if you try www.thedailyneopets.com? Does that work?

Share this post


Link to post
Share on other sites
Just now, Scoobert_Doo said:

What happens if you try www.thedailyneopets.com? Does that work?

Nope, same graphic-less site. I also tried it with http instead of https and and basically any other way I could think of, but it's not loading the CSS at all for me anymore.

Share this post


Link to post
Share on other sites
5 minutes ago, Scoobert_Doo said:

Have you tried clearing you cache?

@Mouseykins, @hrtbrk, I wonder if this is something with The Daily Neopets site itself that @Ian may need to look into?

It could be a new feature with Firefox. It was released on 5 July 2018. I'll try looking into that.

I have, but that didn't have any effect either. If you're also seeing it when typing the site into the address bar, then it might be an issue with TDN, and not just with my laptop/settings (although I still wouldn't rule that out). The site I linked to above does mentions that Firefox will withdraw support for certain certificates:

Quote

After a number of irregularities with certificates issued by Symantec root authorities came to light, browser vendors including Mozilla are gradually removing trust from these certificates in their products. In a first step, Firefox 60 will no longer trust certificates chaining up to Symantec root authorities (including all Symantec brands GeoTrust, RapidSSL, Thawte, and VeriSign) which were issued before 2016-06-01. In Firefox 63 this removal of trust will be extended to all Symantec certificates regardless of their issuing date.

 

Share this post


Link to post
Share on other sites
1 minute ago, Nielo said:

I have, but that didn't have any effect either. If you're also seeing it when typing the site into the address bar, then it might be an issue with TDN, and not just with my laptop/settings. The site I linked to above does mentions that Firefox will withdraw support for certain certificates:

 

And that's what doesn't make sense. "The Daily Neopets" is not a secure web site. If the site isn't secure, it will not have a certificate. The Forums are, but not TDN itself. Why Firefox is putting a "https" in front of "thedailyneopets.com" must be something with Firefox. So try clicking this link:

http://www.thedailyneopets.com

Also, do you have Firefox clear you cache, cookies, and history when you close it?

Share this post


Link to post
Share on other sites
35 minutes ago, Scoobert_Doo said:

And that's what doesn't make sense. "The Daily Neopets" is not a secure web site. If the site isn't secure, it will not have a certificate. The Forums are, but not TDN itself. Why Firefox is putting a "https" in front of "thedailyneopets.com" must be something with Firefox. So try clicking this link:

http://www.thedailyneopets.com

Also, do you have Firefox clear you cache, cookies, and history when you close it?

I know, and other sites that aren't secure don't give me any trouble. Neither did TDN, until yesterday. And that link is one of the options I'd already tried, and clicking it now, it still only shows me the plain site, no CSS.

I don't, but that's never been a problem before.

Share this post


Link to post
Share on other sites
1 hour ago, Nielo said:

Maybe I should've been clearer on that, but I'm loosely translating it, as my Firefox is in Dutch. Otherwise I'd have just included a screenshot, but the link I put in my last post shows almost the same thing, except that the lock on TDN doesn't have a red line over it, but a yellow/orange exlamation mark.

Got to say, my browser doesn't have that lock next to the url for TDN now (it used to on my old laptop). There's a green one up there for the forums, but I have to click on the info i to get a not secure message on TDN itself.

O8Y216J.jpg

Share this post


Link to post
Share on other sites
3 minutes ago, jellysundae said:

Got to say, my browser doesn't have that lock next to the url for TDN now (it used to on my old laptop). There's a green one up there for the forums, but I have to click on the info i to get a not secure message.

O8Y216J.jpg

Interesting. This is what mine looks like (in Dutch):

TDN_security_lock.jpg

(I tried leaving out everything including the www. from before the site's name, but it still loads with the https in front of it. ?

Share this post


Link to post
Share on other sites
1 hour ago, Nielo said:

Interesting. This is what mine looks like (in Dutch):

TDN_security_lock.jpg

(I tried leaving out everything including the www. from before the site's name, but it still loads with the https in front of it. ?

Ok. Let's see if this helps/works.

In Firefox:

1. Click on the "Menu" button - three, horizontal lines, top, right corner of Firefox.

2. Look for, and select "Options".

3. On the left side, click on "Privacy & Security".

4. On the right, look for "Cookies and Site Data" and click the "Manage Data" button.

5. In the search text field, start typing, without the quotes, "thedailyneopets".

6. If it finds any, click on it to highlight it, and click the "Remove Selected" button. Do this for any found. Please note, if you are logged into "myTDN", it may log you out. I recommend you logout of "myTDN" before removing it. You may find one entry for "thedailyneopets.com" and one for "my.thedailyneopets.com". Remove both.

7. When those have been removed, click the "Save Changes" button.

Next, we will clear the "history" entry for The Daily Neopets.

1. Click on the "Menu" button, as before.

2. Look for and click on "Library".

3. Click on "History", then "View History Sidebar".

4. In the "History" sidebar search text field, type, without the quotes, "https://thedailyneopets.com".

5. You may only see one entry. If you do, right-mouse click on it, and select "Forget About This Site".

6. You may close the "History" sidebar, by clicking the "X", if you wish.

Now, open a new tab and try going to thedailyneopets.com. If you see anything directing you to "http://", select that.

Let us know if this helped.

Share this post


Link to post
Share on other sites

@Scoobert_Doo As for the first part, considering I'd already cleared my cache & deleted my cookies a few hours, and hadn't logged in to myTDN again, I only found one entry.

Deleting the site from my history didn't work either; after doing so, I tried both typing it in without https/http/www, and following the link you posted earlier and the one from the forums.

But I decided to restart my browser again, just to see what would happen, and while clicking the link from the forums still doesn't work for me, typing it in now does load everything correctly again. So I might try clearing the history for the forums as well (again), and restart my browser (again). Computers are fun! (Sometimes I wonder why I decided to become a software engineer. ?)

*Edit: Only the first try worked; all my other tries (including copying the working url and pasting it into a new tab and deleting the history again) are failing. I'm just going to let it rest for a bit and see if anything changes over the next couple of days. All the links are working, and it's not an issue with TDN, so it's not urgent.)

Share this post


Link to post
Share on other sites

I made the instructions so anyone would only have to delete the cookies and "data" and history for The Daily Neopets, so you wouldn't have to clear everything out. But, since you've already done that, it works too. Sometimes people are reluctant to delete everything because they visit a lot of sites, and I understand. It can take time and be a "pain" to get everything back the way you like to see it, or are used to seeing.

Well, it seems the issue is solved, for now?

Share this post


Link to post
Share on other sites
On 7/21/2018 at 11:17 PM, Scoobert_Doo said:

I made the instructions so anyone would only have to delete the cookies and "data" and history for The Daily Neopets, so you wouldn't have to clear everything out. But, since you've already done that, it works too. Sometimes people are reluctant to delete everything because they visit a lot of sites, and I understand. It can take time and be a "pain" to get everything back the way you like to see it, or are used to seeing.

Well, it seems the issue is solved, for now?

Yes, it's always best to write instructions down in as much detail as possible, so everyone can understand them. :smile:

(And I actually dislike clearing my cache/cookies as well, but in cases like this I usually do so anyway.)

Not really, unfortunately. Aside from that one initial instance after deleting everything and restarting my browser, it went back to not loading the CSS right away, and hasn't done it correctly since. ?

*Edit (August 1): I was hoping going on holiday for a few days and not touching my laptop would've cleared this issue up as mysteriously and suddenly as it appeared, but alas... ? Still going strong.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...